『Windows間で巨大ファイル転送中にnetwork pathを見失う』 の クチコミ掲示板

 >  > PC何でも掲示板
クチコミ掲示板 > パソコン > PC何でも掲示板

『Windows間で巨大ファイル転送中にnetwork pathを見失う』 のクチコミ掲示板

RSS


「PC何でも掲示板」のクチコミ掲示板に
PC何でも掲示板を新規書き込みPC何でも掲示板をヘルプ付 新規書き込み



ナイスクチコミ0

返信13

お気に入りに追加

解決済
標準

PC何でも掲示板

転送中のエラー

ネットワーク構造

数日前から、大きなファイルをWindows間で転送中に 添付のメッセージが出て転送が中断することが頻発しています。

100MB程度ならほぼ100%OKのようですが、G単位だと ほぼ確実に転送途中でネットワークパスがないというエラーが発生します。(時々, 成功する事もある)。

Win7-1 : ASUS M4A78-EM + AMD 965BE (8Gメモリ) + Win7Home SP1 or Win8
Win7-2 : ASUS P8Z68M-Pro + Core i7 3770 (8Gメモリ) + Win7Home SP1

社内ネットワークで暗号化は128bit, ホームグループは未使用。
有線Gbit環境, LANケーブルは対応品、ジャンボフレームはDisable

ただし、通信が全く出来ない訳ではなく、この現象が起きた直後に、VNCなどのリモートデスクトップで双方をアクセスする事は出来ます。FTPでの転送も相互に問題はないです。

つまり、TCIPレベルでの通信は問題がなく、Windowsネットワークだけが不具合があるように見えます。

TCPで問題がないので、ハードではないように思えます。念のため、LANケーブルを交換、抜き差ししてみましたが、関係なしです。

-GigaBit HubとGiga対応ルータは 1台ずつしかないので、交換して様子を見ることも出来ません。
-Win7-1は Win8との2重ブートですが、Win8でも現象は同じです。
-暗号化レベルは40bitに合わせても同じです。

数日前まではこんな不可解な事象は発生していませんでした。変更したのは、恐らく両端末をWOLを有効にした位。無効に変わりませんが。

TCPIPでの通信は問題ないのに、Windowsネットワークだけがおかしくなるという場合どう調べたらよいのでしょうか?

書込番号:15528208

ナイスクチコミ!0


返信する
クチコミ投稿数:23660件Goodアンサー獲得:2171件

2012/12/25 16:48(1年以上前)

ネットワークブラウザー周りの不具合だと思うんだけど、、、、Net BTの設定とか変えた直後に良くおかしくなる。

キャッシュの同期の問題なんでしばらくしたら直ったりするんだけど、原因不明。

1時間に一回しか同期しないとかその辺のゴミ仕様がいまだに使われてるんで、、、

WebDAVにでも変えたほうがいいかもしれない。または、ホームグループ使う。

書込番号:15528229

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/25 17:04(1年以上前)

これ、有名な現象なのですか? 
ハードウェアではなく、ソフトウェア関係の問題の可能性が高いのですか?

書込番号:15528270

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/25 17:31(1年以上前)

一応下記をやってみたけど、状況全く変わりません。

1. netbt -R
2. netuse X: でネットワークドライブを割り当ててそこからコピー
3. セキュリティソフト全停止
4. 共有してる各フォルダを1つにする

いっそ、一月前位の システムイメージに戻してみようかな... なんとなくそれでも再現する予感がする。

書込番号:15528363

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/25 18:04(1年以上前)

このまま固まる

WebDAVに変更しても同じです。

G単位ならファイルサイズに関係ないのか、今日は何個試しても残り15秒位の所で固まります。
こうなると、ネットワークパスが見つからないのエラーが出るまでずーっと固まります。

この状態でも FTP, VNCは影響が全くないです -(*)

(*)という事は、ケーブル、ハブ、ルータなどの機器の問題ではないと判断してよいのでしょうか? 

ネットワークのエラーの見極めは難しいです。

書込番号:15528493

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/25 18:15(1年以上前)

>今日は何個試しても残り15秒位の所で固まります。
=>
これ嘘でした。10G位コピーしたら残り45秒で固まりましたから...

書込番号:15528536

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/25 18:56(1年以上前)

突然プッツリ 切れる(tcpip & NASとは繋がってるのに)。

Win7-2も Windows8でブートしてみましたが、現象再現しました。
図のように、残り数十秒の所で、突然、転送相手がいなくなったような動きをします。
(Win7, Win8無縁という点だけ見るとハードの問題にも見える。)

この状態で、ルータの簡易NAS(Samba)とのGIGA単位の転送は出来る、FTPもOK, VNCもOKなのでこれまた謎。Sambaの元祖同士だけが問題...

Win7-1, 7-2を 適当なLinuxでブートして同じことしてみるかなぁ...

書込番号:15528674

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/29 02:04(1年以上前)

IRPStackSizeで検索してたら Microsoft Communityで僕と全く同じ相談を見つけた:

http://answers.microsoft.com/ja-jp/windows/forum/windows_7-networking/windowsxp%E3%81%AEpc%E3%81%8B%E3%82%89windows7/c7221b92-4528-4ca9-b01d-0fc165e87a24

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\IRPStackSize

を 標準の15(10進)から少しずつ増やして様子を見る方法だ。大きくてもダメらしい。
明日はここを調べてみよう。

書込番号:15542002

ナイスクチコミ!0


クチコミ投稿数:6239件

2012/12/31 12:00(1年以上前)

IRPStackSizeは 15-20まで変更したが現象変わらず。
BIOSの CMOSクリア、 BIOSの版数アップ, LANドライバ最新版

全て徒労に終わった。

やむなく, SSDをTrueImageで 12/10頃のイメージにリカバリした。
すると、幸運な事に 現象は起きなくなった。 15G位のファイルを何度かやりとりしたがとぎれる事はない。
やはり問題はメインのWin7機にだけ存在したようだ。


ただし、原因は不明だ。ジャンボフレームをシステム全体で 無効にしたのが問題なのだろうか? リカバリ後のメイン機は 9Kになってる。 相手のWin8は無効、9K,7K ... いくつに設定しても現象は起きない。

しかし、僕と同様の現象”巨大ファイル転送中にネットワークにアクセスできなくなる”はネット上に沢山の事例が報告されてる。 一部のごく初歩的なユーザの勘違いをのぞいて、原因が分かってるのは一つもなかった。

みんな対処療法で、こうしたら起きなくなったとか書いてある。 

こういうのは、多分、根本原因はWindowsのバグなんだろう。

企業のシステムで同じ事が起きたら、困るだろうなぁ...

書込番号:15551324

ナイスクチコミ!0


クチコミ投稿数:6239件

2013/01/28 12:30(1年以上前)

>こういうのは、多分、根本原因はWindowsのバグなんだろう。
==>
結局、JumboFrameは、1機種を除いて Disableにしてる。P5K-Eの Marvellは JumboFrameをOFFには出来ない。

現象は、最近は、起きたり起きなかったりに変わった。起きるときは、力強く何度も再現する。

ネットワーク関連のトラブルの原因はやっぱ複雑だ。 原因をWindowsに求めたくなるが、そう結論付けるのは、まだ早そうだ。 

書込番号:15682293

ナイスクチコミ!0


KAZU0002さん
殿堂入り銅メダル クチコミ投稿数:33585件Goodアンサー獲得:4804件

2013/01/30 21:39(1年以上前)

スイッチとは、スイッチングHUBのことだと思いますが。

HUBを使わずにルーターのHUBに2台とも直結する/ルーターのHUBを使わずに、スイッチングHUBに2台とも直結する

この辺は試してみましたか?
HUBを交換したら治った経験がある物で。参考まで。

書込番号:15693635

ナイスクチコミ!0


クチコミ投稿数:6239件

2013/02/01 08:24(1年以上前)

アドバイスありがとうございます。

現象が強力に再現するとき、ルータを再起動するとしばらくは起きなくなるようにも思えます。
残念ながら、またしばらくすると起きます。

当初、JumboFrame非対応HUBにJumboFrameが載ってるせいかとも考えましたが、DisableにできないP5K-Eをネットワークから切断しても起きるときは起きます。

安物の PLANEXのルータのハブ部が原因ですかね... 価格.comのレビューとは違って、ネット接続や無線は快調なのですが....

すぐには無理ですが、いずれ交換してみます。


書込番号:15699972

ナイスクチコミ!0


クチコミ投稿数:6239件

2013/02/01 08:29(1年以上前)

あ、書き忘れ

>HUBを使わずにルーターのHUBに2台とも直結する/ルーターのHUBを使わずに、スイッチングHUBに2台とも直結する
=>
これは初期の段階で試してます。どちらも現象再現します。

HUB使わずに直結はまだ試してないなぁ... ネットワークトラブルは、付けたり外したりとっても面倒ですね。

書込番号:15699986

ナイスクチコミ!0


クチコミ投稿数:6239件

2013/05/08 21:39(1年以上前)

最後の書込みから約3ヶ月、ネットワーク上の全PCを(P5K-E)を除いて、ジャンボフレーム OFFで使用しています。
現象は再現しなくなりました。 

P5K-Eは、完全OFFには出来ないけど、最小で。

以前は、ジャンボフレーム OFFでも 確実に再現してましたが、なぜでしょうね... 不思議。 Windowsもアップデートが沢山あったから、もう以前の環境ではないですが....

書込番号:16110846

ナイスクチコミ!0


クチコミ一覧を見る


価格.com Q&Aを見る

クチコミ掲示板検索



検索対象カテゴリ
を対象として

新着ピックアップリスト

ピックアップリストトップ

新製品ニュース Headline

更新日:4月9日

クチコミ掲示板ランキング

(パソコン)